Esta web utiliza cookies, puedes ver nuestra política de cookies, aquí Si continuas navegando estás aceptándola

GNS3 + Router Cisco + Router Mikrotik-QEmu + Hosts VirtualBox


En este artículo vamos a hacer uso de un número de tecnologías muy vario pinto:

  • GNS3: Simulador de redes muy completo
  • Dinamyps: Emular de hardware Cisco
  • QEmu: Emulador de procesadores y software de virtualización
  • VirtualBox: Software de virtualización

En este escenario vamos a utilizar un router Cisco, uno Mikrotik y dos máquinas virtuales Gentoo que actuarán como hosts, el tener máquinas virtuales reales nos permitirá una mayor flexibilidad y poder probar cualquier tipo de ataque/exploit sobre routers Mikrotik o Cisco.

Habrá 3 redes:

  1. Entre la Gentoo-1 y el router Mikrotik: 192.168.2.0/24
  2. Entre el router Mikrotik y el router Cisco: 192.168.1.0/24
  3. Entre el router Cisco y la Gentoo-3: 192.168.3.0/24

Instalamos todo lo necesario:

emerge -av app-emulation/qemu net-misc/gns3-server net-misc/gns3-gui app-emulation/dynamips net-misc/ubridge

Para poder enlazar la arquitectura de red de GNS3 con las máquinas virtuales de VBox se utilizarán ubridges, añadimos el usuario que correrá el software VBox, GNS3 y Qemu al grupo ubridge:

gpasswd -a kr0m ubridge

Arrancamos GNS3:

gns3

Configuramos el path del binario ubridge:

Edit -> Preferences -> Server -> Ubirdge path:
/usr/bin/ubridge

Creamos las máquinas virtuales de Qemu y VirtualBox en la config de este modo aparecerán como disponibles en el menú de elementos de red disponibles:

Edit -> Preferences -> Qemu -> Qemu VMs:
New
Edit -> Preferences -> VirtualBox -> VirtualBox VMs:
New

Creamos una imagen de disco de 1G donde instalaremos RouterOS de Mikrotik:

qemu-img create -f qcow2 mikrotik.img 1024M

Nos bajamos la imagen de instalación de RouterOS de la web de Mikrotik:

https://mikrotik.com/download/archive

Arrancamos desde la ISO e instalamos el SO y las tools:

qemu-system-x86_64 mikrotik.img -boot d -cdrom mikrotik-6.40.9.iso

Arrancamos el router desde el disco duro:

qemu-system-x86_64 mikrotik.img -boot c

Hacemos login en el router:

admin
ENTER

Configuramos las dos interfaces y le hacemos saber por routing estático que la red 192.168.3.0/24 es accesible a través de 192.168.1.2:

[admin@MikroTik] >
/ip address
add address=192.168.1.1/24 interface=ether1 network=192.168.1.0
add address=192.168.2.1/24 interface=ether2 network=192.168.2.0
/ip route add dst-address=192.168.3.0/24 gateway=192.168.1.2

Configuramos en el router Cisco las dos interfaces y le hacemos saber por routing estático que la red 192.168.2.0/24 es accesible a través de 192.168.1.1:

Cisco3640c3640#configure terminal
Cisco3640c3640(config)#interface FastEthernet0/0
Cisco3640c3640(config-if)#ip address 192.168.1.2 255.255.255.0
Cisco3640c3640(config-if)#no shutdown
Cisco3640c3640(config-if)#exit

Cisco3640c3640(config)#interface fastEthernet1/0
Cisco3640c3640(config-if)#ip address 192.168.3.1 255.255.255.0
Cisco3640c3640(config-if)#no shutdown
Cisco3640c3640(config-if)#exit

Cisco3640c3640(config)#ip route 192.168.2.0 255.255.255.0 192.168.1.1
Cisco3640c3640(config)#end
Cisco3640c3640#copy running-config startup-config

NOTA: Al meter máquinas virtuales de VirtualBox desde GNS3 (arrastrando desde la izquierda) estas directamente tendrán la config de red con ubridge.

Configuramos la ip y el gw de la primera Gentoo:

ifconfig enp0s3 192.168.2.2 netmask 255.255.255.0
route add -net 192.168.2.0/24 dev enp0s3
route add default gw 192.168.2.1

Configuramos la ip y el gw de la segunda Gentoo:

ifconfig enp0s3 192.168.3.2 netmask 255.255.255.0
route add -net 192.168.3.0/24 dev enp0s3
route add default gw 192.168.3.1

Ahora las dos redes ya están enrutadas y totalmente accesibles.


Autor: Kr0m -- 10/11/2018 19:15:06